存档

2011年5月 的存档

VLAN的通讯:单臂路由配置实例

2011年5月16日 没有评论

在学习单臂路由的配置之前,建议大家先学好VLAN,起码要知道VLAN是怎么配置的,这样学单臂路由就轻松多了。

先来了解一下什么是单臂路由,为什么要用到单臂路由。VLAN(虚拟局域网)技术是路由交换中非常基础的技术。在网络管理实践中,通过在交换机上划分适当数目的vlan,不仅能有效隔离广播风暴,还能提高网络安全系 数及网络带宽的利用效率。划分vlan之后,vlan与vlan之间是不能通信的,只能通过路由或三层交换来实现。我们知道路由器实现路由功能通常是数据 报从一个接口进来然后另一个接口出来,现在路由器与交换机之间通过一条主干现实通信或数据转发,也就是说路由器仅用一个接口实现数据的进与出,因为我们形 象地称它为单臂路由。单臂路由是解决vlan间通信的一种廉价而实用的解决方案。

下面请看图,PC-A和PC-B分别属于vlan10和vlan20,Switch2950是一个cisco的二层交换机,型号2950,欲实 现vlan10和vlan20的通信,我们要增加一个路由器来转发vlan之间的数据包,路由器与交换机之间使用单条链路相连(图中画红线),这条链路也 叫主干,所有数据包的进出都要通过路由器2600的f0/0端口来现实数据转发。

接下来,结合以上网络拓扑探讨一下单臂路由的配置。图中路由器是cisco的2600系列,交换机采用cisco的2950.

一、配置交换机

二、配置路由器

三、验证

最后配置PC-A和PC-B的IP地址和子网掩码,具体请看图。下面试试PC-A 主机 ping  PC-B主机。实验结果能Ping通,配置成功。

验结果能Ping通,配置成功。

分类: network 标签:

cisco命令大全

2011年5月12日 没有评论

收录最常用的Cisco命令分类如下:
cisco命令大全

1. switch配置命令
(1)模式转换命令
用户模式—-特权模式,使用命令”enable”
特权模式—-全局配置模式,使用命令”config t”
全局配置模式—-接口模式,使用命令”interface+接口类型+接口号”
全局配置模式—-线控模式,使用命令”line+接口类型+接口号”
注:
用户模式:查看初始化的信息.
特权模式:查看所有信息、调试、保存配置信息
全局模式:配置所有信息、针对整个路由器或交换机的所有接口
接口模式:针对某一个接口的配置
线控模式:对路由器进行控制的接口配置
(2)配置命令
show running config 显示所有的配置
show versin 显示版本号和寄存器值
shut down 关闭接口
no shutdown 打开接口
ip add +ip地址 配置IP地址
secondary+IP地址 为接口配置第二个IP地址
show interface+接口类型+接口号 查看接口管理性
show controllers interface 查看接口是否有DCE电缆
show history 查看历史记录
show terminal 查看终端记录大小
hostname+主机名 配置路由器或交换机的标识
config memory 修改保存在NVRAM中的启动配置
exec timeout 0 0 设置控制台会话超时为0
service password-encryptin 手工加密所有密码
enable password +密码 配置明文密码
ena sec +密码 配置密文密码
line vty 0 4/15 进入telnet接口
password +密码 配置telnet密码
line aux 0 进入AUX接口
password +密码 配置密码
line con 0 进入CON接口
password +密码 配置密码
bandwidth+数字 配置带宽
no ip address 删除已配置的IP地址
show startup config 查看NVRAM中的配置信息
copy run-config atartup config 保存信息到NVRAM
write 保存信息到NVRAM
erase startup-config 清除NVRAM中的配置信息
show ip interface brief 查看接口的谪要信息
banner motd # +信息 + # 配置路由器或交换机的描素信息
description+信息 配置接口听描素信息
vlan database 进入VLAN数据库模式
vlan +vlan号+ 名称 创建VLAN
switchport access vlan +vlan号 为VLAN为配接口
interface vlan +vlan号 进入VLAN接口模式
ip add +ip地址 为VLAN配置管理IP地址
vtp+service/tracsparent/client 配置SW的VTP工作模式
vtp +domain+域名 配置SW的VTP域名
vtp +password +密码 配置SW的密码
switchport mode trunk 启用中继
no vlan +vlan号 删除VLAN
show spamming-tree vlan +vlan号 查看VLA怕生成树议

2. 路由器配置命令
ip route+非直连网段+子网掩码+下一跳地址 配置静态/默认路由
show ip route 查看路由表
show protocols 显示出所有的被动路由协议和接口上哪些协议被设置
show ip protocols 显示了被配置在路由器上的路由选择协议,同时给出了在路由选择协议中使用的定时器等信息
router rip 激活RIP协议
network +直连网段 发布直连网段
interface lookback 0 激活逻辑接口
passive-interface +接口类型+接口号 配置接口为被动模式
debug ip +协议 动态查看路由更新信息
undebug all 关闭所有DEBUG信息
router eigrp +as号 激活EIGRP路由协议
network +网段+子网掩码 发布直连网段
show ip eigrp neighbors 查看邻居表
show ip eigrp topology 查看拓扑表
show ip eigrp traffic 查看发送包数量
router ospf +process-ID 激活OSPF协议
network+直连网段+area+区域号 发布直连网段
show ip ospf 显示OSPF的进程号和ROUTER-ID
encapsulation+封装格式 更改封装格式
no ip admain-lookup 关闭路由器的域名查找
ip routing 在三层交换机上启用路由功能
show user 查看SW的在线用户
clear line +线路号 清除线路

3. 三层交换机配置命令
配置一组二层端口
configure terminal 进入配置状态
nterface range {port-range} 进入组配置状态
配置三层端口
configure terminal 进入配置状态
interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-channel port-channel-number} 进入端口配置状态
no switchport 把物理端口变成三层口
ip address ip_address subnet_mask 配置IP地址和掩码
no shutdown 激活端口
例:
Switch(config)# interface gigabitethernet0/2
Switch(config-if)# no switchport
Switch(config-if)# ip address 192.20.135.21 255.255.255.0
Switch(config-if)# no shutdown
配置VLAN
configure terminal 进入配置状态
vlan vlan-id 输入一个VLAN号, 然后进入vlan配态,可以输入一个新的VLAN号或旧的来进行修改。
name vlan-name 可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满的4位数,如VLAN0004是VLAN4的缺省名字
mtu mtu-size (可选) 改变MTU大小

Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end

Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
将端口分配给一个VLAN
configure terminal 进入配置状态
interface interface-id 进入要分配的端口
switchport mode access 定义二层口
switchport access vlan vlan-id 把端口分配给某一VLAN

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#

配置VLAN trunk
configure terminal 进入配置状态
interface interface-Id 进入端口配置状态
switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装ISL 或 802.1Q 或自动协商
switchport mode {dynamic {auto | desirable} | trunk} 配置二层trunk模式。
dynamic auto—自动协商是否成为trunk
dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 配置Native VLAN(802.1q)
或自动模式,trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk
switchport access vlan vlan-id 可选) 指定一个缺省VLAN, 如果此端口不再是trunk
switchport trunk native vlan vlan-id 指定802.1Q native VLAN号
例:
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
定义TRUNK允许的VLAN
configure terminal子 进入配置状态
interface interface-id 进入端口配置
switchport mode trunk 配置二层口为trunk
switchport trunk allowed vlan {add | all | except | remove} vlan-list可选) 配置trunk允许的VLAN.使用add, all, except, remove关健字
no switchport trunk allowed vlan 允许所有VLAN通过

Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
配置Native VLAN(802.1q)
configure terminal 进入配置状态
interface interface-id 进入配置成802.1qtrunk的端口
switchport trunk native vlan vlan-Id 配置native VLAN号
no switchport trunk native vlan 端口配置命令回到缺省的状态
配置基于端口权值的负载均衡
configure terminal 进入Switch 1配置状态
vtp domain domain-name 配置VTP域
vtp mode server 将Switch 1配置成VTP server.
show vtp status 验证VTP的配置
show vlan 验证VLAN
configure terminal 进入配置状态
interface fastethernet 0/1 进入F0/1端口
switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装
switchport mode trunk 配置成trunk
show interfaces fastethernet0/1 switchport 验证VLAN配置
按以上步骤对想要负载均衡的接口进行配置

在另一个交换机上进行此配置
show vlan 当trunk已经起来,在switch2上验证已经学到相的vlan配置
configure terminal 在Switch 1上进入配置状态
interface fastethernet0/1 进入要配置的端口
spanning-tree vlan 8 port-priority 10 将端口权值10赋与VLAN 8.
spanning-tree vlan 9 port-priority 10 将端口权值10赋与VLAN 9.
spanning-tree vlan 10 port-priority 10 将端口权值10赋与VLAN 10.
interface fastethernet0/2 进入F0/2
spanning-tree vlan 3 port-priority 10 将端口权值10赋与VLAN 3.
spanning-tree vlan 4 port-priority 10 将端口权值10赋与VLAN 4
spanning-tree vlan 5 port-priority 10 将端口权值10赋与VLAN 5
spanning-tree vlan 6 port-priority 10 将端口权值10赋与VLAN 10
end 退出
show running-config 验证配置
copy running-config startup-config 保存配置

配置STP路径值的负载均衡
Trunk1走VLAN8-10,Trunk2走VLAN2-4

configure terminal 进入 Switch 1配置状态
interface fastethernet 0/1 进入F0/1
switchport trunk encapsulation {isl | dot1q | negotiate}配置封装
switchport mode trunk 配置Trunk,缺省是ISL封装
exit 退回
在F0/2口上重复2-4步骤
exit 退回
show running-config 验证配置
show vlan验证switch1 已经学到Vlan
configure terminal 进入配置状态
interface fastethernet 0/1 进入F0/1
spanning-tree vlan 2 cost 30 设置Vlan2生成树路径值为30
spanning-tree vlan 3 cost 30 设置Vlan3生成树路径值为30
spanning-tree vlan 4 cost 30 设置Vlan4生成树路径值为30
end 退出
在switch1的F0/2上重复9-11步骤设置VLAN8,9,10生成树路径值为30
end 退出
show running-config 验证配置
copy running-config startup-config 保存配置
补充:CISCO命令集——路由选择协议及排障
*ip route命令

Router(config)# ip route <目录网络或子网号> [子网掩码] <下一路由器IP地址 | 从本地出口的地址> [管理距离0~255,默认为1]
(注:静态地址配置)

*ip default-network命令

Router(config)# ip default-network <目标网络号>
(注:配合路由协使用,用其中的一个动态路由号作默认路由配置)
Router(config)# ip route 0.0.0.0 0.0.0.0 <下一路由器IP地址 | 从本地出口的地址>
(注:只有一个公网地址时,在出口路由器上的配置)

*内部路由选择协议

*使用router和network命令

Router(config)# router <路由协议rip | igrp | eigrp | ospf | is-is等> [自主系统号]
Router(config-router)# network <直接相连的要用此路由协议的网络号>
Router(config-router)# network <直接相连的要用此路由协议的网络号>

*路由信息协议RIP

Router(config)# router rip
Router(config-router)# network <直接相连的要用rip协议的有类别网络号>
Router# show ip protocols
Router# show ip route
Router# debug ip rip

*内部网关路由协议IGRP

Router(config)# router igrp <自主系统号>
Router(config-router)# network <直接相连的要用igrp协议的有类别网络号>
Router# show ip interface
Router# show ip protocols
Router# show ip route
Router# debug ip rip

*排除网络故障

排除网络故障的一个总体模型

Router# ping <有故障的主机 | 有故障的IP地址>
Router# show ip route
Router# show interface <有故障的接口>
Router# show run

*IP的故故障排除

检查可用的路由

Router# show ip route <有故障的IP地址>
27.4.4 跟踪路由(Tracing the Route)
SUN-A> traceroute <有故障的主机 | 有故障的IP地址>
C:\windows\> winipcfg
C:\windows\> ipconfig
C:\windows\> ipconfig / all
C:\windows\> tracert <有故障的主机 | 有故障的IP地址>

使用扩展的ping来跟踪连接性

Router# ping

*其它可能的故障

一个地址解析(ARP)的故障

Router# show arp
Router# show interface <有故障的接口>
C:\windows\> arp -a
SUN-A> arp –a

验证终端系统的路由表
C:\windows\> netstat –rn
C:\windows\> route –f add 0.0.0.0 mask 0.0.0.0 <需要添加入的网关地址>
C:\windows\> route [–f ] [[print | add | delete | change] [destination] [mask netmask] [gateway]]
C:\windows\> route add mask <网络掩码> <网关ip地址>
C:\windows\> route delete mask <网络掩码> <网关ip地址>
C:\windows\> nbtstat <相应的参数>
SUN-A> netstat -rn路由器

分类: network 标签:

活动目录中域控制器的五种操作主机角色

2011年5月11日 没有评论

winserver的ad和NT域的区别在于不再有主域控制器和辅助域控制器

每个林中有五种操作主机角色,一台域控制器可以承担一种或者多种角色,或者不承担任何角色。

比如一个域中有两台域控制器,一台可以是架构主机,域命名主机,主域控制器仿真主机(PDC),相对ID主机(RID),基础结构主机,五种角色,另一台域控制器什么角色也不是,只是一台额外域控制器。

在林范围内有两种角色:架构主机和域命名主机,域范围内有主域控制器仿真主机(PDC),相对ID主机(RID)和基础结构主机。这五种角色在林中和域中都是唯一的。

五种角色的作用:
架构主机:一个林中只有一台架构主机,控制对林架构的全部更新。
域命名主机:一个林中只有一台域命名主机,控制林中域的新增和删除,防止域名重复。
主域控制器仿真主机(PDC):一个域只有一台PDC,管理来自客户端的密码更改,最小化密码复制等待时间,同步整个域中所有域控制器的时间。
相对ID(RID):一个域中只有一台RID,把RID分给域中各个域控制器,每次当DC创建用户、组或计算机对象时,它就给该对象指派一个唯一的安全 ID(SID)。SID包含一个域SID(它与域中创建的所有SID相同)和一个RID(它对域中创建的每个SID是唯一的)。对象的SID=域 SID+RID。
基础结构主机:一个域只有一台基础结构主机,负责更新从它所在的域中的对象到其他域中对象的引用,基础结构主机将其数据与全局编录的数据进行比较,全局编 录通过复制操作接受所有域中对象的定期更新,从而使全局编录的数据始终保持更新.如果基础结构主机发现数据已过时时,则它会从全局编录请求更新的数据,然 后,基础结构主机再将这些更新的数据复制到域中的其他DC!

查看基础结构主机、PDC模拟器、RID主机角色
命令行界面:
结构主机:  dsquery  server  -hasfsmo infr
PDC模拟器:dsquery  server  -hasfsmo pdc
RID主机:  dsquery  server  -hasfsmo rid
图形界面:
1、        打开“运行”窗口,输入dsa.msc ,回车打开Active Directory 用户和计算机
2、        右键单击域节点,然后单击“操作主机”。
3、        在“结构”选项卡的“操作主机”下,查看当前结构主机的名称
同上方法,可查看PDC模拟器以及RID主机角色。

查看域命名主机角色
命令行界面:
域命名主机角色:dsquery  server  -hasfsmo name
图形界面:
1、        打开“运行”窗口,输入domain.msc ,回车打开Active Directory 域和信任关系。
2、        右键单击Active Directory 域和信任关系,然后单击“操作主机”。
3、        在“域命名操作主机”下,查看当前的域命名操作主机。

查看架构主机角色
命令行界面:
架构主机角色:dsquery server -hasfsmo  schema
图形界面:
1、        打开“运行”窗口,输入schmmgmt.msc ,回车打开Active Directory 架构管理单元。
2、        右键单击Active Directory 架构管理单元,然后单击“操作主机”。
3、        在“当前架构主机”下,查看当前架构主机。

分类: windows 标签: ,

凡事不要看表面

2011年5月11日 没有评论

 

凡事不要看表面

凡事不要看表面

分类: life 标签:

linux screen 命令详解

2011年5月10日 没有评论

功能说明:

使 用telnet或SSH远程登录linux时,如果连接非正常中断,重新连接时,系统将开一个新的session,无法恢复原来的 session.screen命令可以解决这个问题。Screen工具是一个终端多路转接器,在本质上,这意味着你能够使用一个单一的终端窗口运行多终端 的应用。

语  法:

screen [-AmRvx -ls -wipe][-d <作业名称>][-h <行数>][-r <作业名称>][-s ][-S <作业名称>]

补充说明:

screen为多重视窗管理程序。此处所谓的视窗,是指一个全屏幕的文字模式画面。通常只有在使用telnet登入主机或是使用老式的终端机时,才有可能用到screen程序。

参  数:

-A  将所有的视窗都调整为目前终端机的大小。
-d <作业名称>  将指定的screen作业离线。
-h <行数>  指定视窗的缓冲区行数。
-m  即使目前已在作业中的screen作业,仍强制建立新的screen作业。
-r <作业名称>  恢复离线的screen作业。
-R  先试图恢复离线的作业。若找不到离线的作业,即建立新的screen作业。
-s  指定建立新视窗时,所要执行的shell。
-S <作业名称>  指定screen作业的名称。
-v  显示版本信息。
-x  恢复之前离线的screen作业。
-ls或–list  显示目前所有的screen作业。
-wipe  检查目前所有的screen作业,并删除已经无法使用的screen作业。

常用screen参数:

screen -S yourname -> 新建一个叫yourname的session
screen -ls -> 列出当前所有的session
screen -r yourname -> 回到yourname这个session
screen -d yourname -> 远程detach某个session
screen -d -r yourname -> 结束当前session并回到yourname这个session

在每个screen session 下,所有命令都以 ctrl+a(C-a) 开始。

C-a ? -> Help,显示简单说明
C-a c -> Create,开启新的 window
C-a n -> Next,切换到下个 window
C-a p -> Previous,前一个 window
C-a 0..9 -> 切换到第 0..9 个window
Ctrl+a [Space] -> 由視窗0循序換到視窗9
C-a C-a -> 在两个最近使用的 window 间切换
C-a x -> 锁住当前的 window,需用用户密码解锁
C-a d -> detach,暂时离开当前session,将目前的 screen session (可能含有多个 windows) 丢到后台执行,并会回到还没进 screen 时的状态,此时在 screen session 里    每个 window 内运行的 process (无论是前台/后台)都在继续执行,即使 logout 也不影响。
C-a z -> 把当前session放到后台执行,用 shell 的 fg 命令則可回去。
C-a w -> Windows,列出已开启的 windows 有那些
C-a t -> Time,显示当前时间,和系统的 load
C-a K -> kill window,强行关闭当前的 window
C-a [ -> 进入 copy mode,在 copy mode 下可以回滚、搜索、复制就像用使用 vi 一样
C-b Backward,PageUp
C-f Forward,PageDown
H(大写) High,将光标移至左上角
L Low,将光标移至左下角
0 移到行首
$ 行末
w forward one word,以字为单位往前移
b backward one word,以字为单位往后移
Space 第一次按为标记区起点,第二次按为终点
Esc 结束 copy mode
C-a ] -> Paste,把刚刚在 copy mode 选定的内容贴上

分类: linux 标签:

5月23日发布CentOS 6

2011年5月10日 没有评论

CentOS 6 发布

来自 CentOS 邮件列表的消息:

Centos发布一网站关于QA工作组的进展。网址为http://qaweb.dev.centos.org/qa
该网站还提供了一消息,CentOS 6 将在5月23日最终与大伙见面。

但该网站还声明,这只是他们的一个目标,最终时间可能还有变数。

分类: life 标签: ,

如何查看windows2003系统是32bit位还是64bit位?

2011年5月10日 没有评论
windows 2003 是32位还是64位
开始:->运行->输入:Winver->确定.

如果你没有看到”Limited Edition”就证明你是32-bit, 业界97%的Windows Server都是32-bit的, Windows Server 2003 64-bit supports 64-bit Itanium Hardware. 中小企业用户没有必要用到64bit的OS.

关于win2003系统64位的技术资料:
http://www.microsoft.com/windowsserver2003/64bit/aslefaq.mspx

分类: windows 标签: , ,

10种意想不到的验证码风格设计

2011年5月4日 没有评论

众所周知,验证码就是帮助我们的网站防止计算机生成答案。今天的这10个用户体验绝佳、令人意想不到的验证码设计风格,推荐给大家。


1. QapTcha

QapTcha – 拖曳式jQuery验证码系统。作为用户,我们只需移动滚动条。

网站验证码风格

2. buttonCaptcha

这个要复杂点,需要拖动目标字母。

网站验证码风格

3. Fancy Draggable Captcha

这个很有意思,我们要解决这个小谜题,拖曳式的。
网站验证码风格

4. Ajax Fancy Captcha

又一个很奇特的,我们需要拖动提示目标物到圈中。
网站验证码风格

5. Sexy Captcha

像小孩子玩儿的拼图游戏。

6. simpleCaptcha

玩具验证码,选一个吧^_^。

网站验证码风格

7. slideLock

拖动滚动条来解锁吧。

网站验证码风格

8. Captcha PHP

动画验证码。

网站验证码风格

9. NuCaptcha

输入flash视频中的红字母就对了。

网站验证码风格

10. identiPIC

看图识字游戏。

网站验证码风格

分类: webapp 标签:

Facebook 网站所使用的开源软件一览表

2011年5月4日 没有评论

 

Facebook 是全球首屈一指的社交网络平台,该网站采用了很多开源软件,Facebook 采用的编程语言包括:Java, Ruby, PHP, Python, Objective-C.

下面是 Facebook 正在使用或者贡献的开源软件详细列表和介绍:

Apache Cassandra是一套开源分布式Key-Value存储系统。它最初由Facebook开发,用于储存特别大的数据。

MySQL 这个不需要在介绍什么了吧,使用最为广泛的开源数据库。

Memcached 是一个高性能的、分布式的内存对象缓存系统。

Scribe 旨在帮助Facebook处理服务器上的大量数据,正像Scribe网页所述“如经常访问Facebook,请使用Scribe。”具体而言,Scribe就是一台服务器,实时收集用网站日志信息。

Thrift 是一个可伸缩的跨语言的服务开发框架。Key-Value 存储服务器 Cassandra 就是使用 Thrift 作为其客户端API的。

FlashCache 是一个适合一般应用场景的 MySQL缓存优化模块。

Hadoop 并不仅仅是一个用于存储的分布式文件系统,而是设计用来在由通用计算设备组成的大型集群上执行分布式应用的框架。

Hive 是一个基于Hadoop的数据仓库平台。通过hive,我们可以方便地进行ETL的工作。hive定义了一个类似于SQL的查询语言:HQL,能 够将用户编写的QL转化为相应的Mapreduce程序基于Hadoop执行。

Open Graph protocol 可让你的任何网页变成社交图谱。http://ogp.me/

OpenCompute – 一个开源硬件项目,提供高能效的数据中心。http://opencompute.org/

Tornado web server 是使用Python编写出來的一个极轻量级、高可伸缩性和非阻塞IO的Web服务器软件,著名的 Friendfeed 网站就是使用它搭建的。

Varnish cache 是一款高性能的开源HTTP加速器,挪威最大的在线报纸 Verdens Gang (http://www.vg.no) 使用3台Varnish代替了原来的12台squid,性能居然比以前更好。

分类: life 标签: